Issues after upgrading to v2.381?

Having problems with the panel? Have questions? Post here!
Post Reply
Cats869
Posts: 6
Joined: Wed Apr 29, 2020 11:14 pm

Issues after upgrading to v2.381?

Post by Cats869 »

Hello,

I recently upgraded my EzUGCC version from v2.18 to v2.381 and it appears that HTTPS has stopped working though regular HTTP still works fine.
Has anyone else experienced a similar issue? Not sure if this issue may be due to something else like a configuration issue and not necessarily an issue with the new software version? Checked my config files and they point to the right SSL port so I don't know what could be causing the issue.

I looked in the logs and see this:

EzUGCC-www.log

Code: Select all

26/2020 6:01:52 PM:		Running from C:\Program Files\EzUGCC on address any, port 55777 serving C:\Program Files\EzUGCC\UGCCPanel as virtual root /
9/26/2020 6:01:52 PM:		SSL enabled:  False, port=55778, cert=C:\Program Files\EzUGCC\cert.p12
9/26/2020 6:01:52 PM:		Bound to ipv4 0.0.0.0:55777
9/26/2020 6:01:52 PM:		SSL is disabled
ugccmon.log (the lines mentioned below are being spammed constantly)

Code: Select all

09/26/2020 19:56:32	UGCCMon Started (2.381) | Dbtype=sqlite | Interval=30000ms | OS:  Win | Config file:  C:\WINDOWS\system32\ugccmon.cfg | User:  NT AUTHORITY\SYSTEM
09/26/2020 19:56:32	License is not valid, monitor disabled
09/26/2020 19:56:32	Unhandled application crash!  License is not valid
   at #=z5ziuP0RwS4Oa_Nqt8No5nfo=.#=zCfEg_lyaqqPo() in #=q$ca2tb$0xmuAfIe1iz903xN7LGVMd$tPIo8DvV2z46U=:line 411
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
09/26/2020 19:56:34	UGCCMon Started (2.381) | Dbtype=sqlite | Interval=30000ms | OS:  Win | Config file:  C:\WINDOWS\system32\ugccmon.cfg | User:  NT AUTHORITY\SYSTEM
09/26/2020 19:56:34	License is not valid, monitor disabled
09/26/2020 19:56:34	Unhandled application crash!  License is not valid
   at #=z5ziuP0RwS4Oa_Nqt8No5nfo=.#=zCfEg_lyaqqPo() in #=q$ca2tb$0xmuAfIe1iz903xN7LGVMd$tPIo8DvV2z46U=:line 411
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
09/26/2020 19:56:35	UGCCMon Started (2.381) | Dbtype=sqlite | Interval=30000ms | OS:  Win | Config file:  C:\WINDOWS\system32\ugccmon.cfg | User:  NT AUTHORITY\SYSTEM
09/26/2020 19:56:36	License is not valid, monitor disabled
09/26/2020 19:56:36	Unhandled application crash!  License is not valid
   at #=z5ziuP0RwS4Oa_Nqt8No5nfo=.#=zCfEg_lyaqqPo() in #=q$ca2tb$0xmuAfIe1iz903xN7LGVMd$tPIo8DvV2z46U=:line 411
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
09/26/2020 19:56:37	UGCCMon Started (2.381) | Dbtype=sqlite | Interval=30000ms | OS:  Win | Config file:  C:\WINDOWS\system32\ugccmon.cfg | User:  NT AUTHORITY\SYSTEM

Masher
Site Admin
Posts: 3520
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Issues after upgrading to v2.381?

Post by Masher »

When you initially installed, did you configure SSL as part of the install, or did you configure it manually after installation?

Also how did you upgrade? Just trying to figure out what may have happened.

Can you post your EzUGCC-WWW.exe.config file contents?

You may have been using the initial https version where we were testing nginx for SSL, but was removed in later versions and the EzUGCC web server may just need to have ssl enabled via it's .config.

The monitor states the license is not valid. If this is expected (i.e. you don't have a license) you can disable the monitor service.
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

Cats869
Posts: 6
Joined: Wed Apr 29, 2020 11:14 pm

Re: Issues after upgrading to v2.381?

Post by Cats869 »

So when I first installed it initially, it was before the SSL feature was built in natively. Once SSL was built in, I believe I chose some port but then later ended up changing the port so I had to go in manually?

I upgraded by running the latest installer and installing to the default directory and pressed the upgrade button and followed the backup procedures before proceeding with the upgrade.

Thanks for letting me know about the monitor service. I'll look into that more and disable that.

EzUGCC-WWW.exe.config

Code: Select all

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <configSections>
        <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
            <section name="EzUGCC.Settings1" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
        </sectionGroup>
    </configSections>
    <applicationSettings>
        <EzUGCC.Settings1>
            <setting name="Port" serializeAs="String">
                <value>55777</value>
            </setting>
            <setting name="VirtualRoot" serializeAs="String">
                <value>/</value>
            </setting>
            <setting name="AllowDirectoryBrowsing" serializeAs="String">
                <value>False</value>
            </setting>
		 <setting name="ListenIP" serializeAs="String">
                <value>any</value>
            </setting>
          <setting name="PortSsl" serializeAs="String">
            <value>55778</value>
          </setting>
          <setting name="Certificate" serializeAs="String">
            <value>cert.p12</value>
          </setting>
        </EzUGCC.Settings1>
    </applicationSettings>
</configuration>

Masher
Site Admin
Posts: 3520
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Issues after upgrading to v2.381?

Post by Masher »

Ok, add this to your EzUGCC-WWW.exe.config right after the certificate setting

Code: Select all

            <setting name="EnableSSL" serializeAs="String">
              <value>true</value>
            </setting>
It should look similar to

Code: Select all

          <setting name="Certificate" serializeAs="String">
            <value>cert.p12</value>
          </setting>
          <setting name="EnableSSL" serializeAs="String">
           <value>true</value>
          </setting>
        </EzUGCC.Settings1>
Then restart the ezugcc web server

Code: Select all

net stop ugcc-www
net start ugcc-www
SSL then should work. Review the EzUGCC-www.log if it doesn't. Let me know how it turns out.
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

Cats869
Posts: 6
Joined: Wed Apr 29, 2020 11:14 pm

Re: Issues after upgrading to v2.381?

Post by Cats869 »

Hi Masher,

That appears to have done the trick! Thank you! It's all working now :)

Post Reply