Empyrion Dedicated Server

Having problems with the panel? Have questions? Post here!
aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Empyrion Dedicated Server

Post by aptec » Fri Nov 11, 2016 9:11 am

Good Morning,

We're trying to add the Empyrion Dedicated Server to Brainless Panel (licensed edition - EzUGCC version 1.87, SQLite, Windows 10 Pro 64-Bit). The problem we're running into is the panel will start the server, but since it spawns its own background process the panel doesn't detect its running.

I tried searching the forums and Google for this server but I didn't get any results.

The Steam APP ID for the dedicated server is 530870 and may be freely downloaded via SteamCMD using anonymous credentials.

If needed, this is what we use:

Code: Select all

steamcmd +login anonymous +app_update 530870 +quit
The game comes with a pre-made BAT file to launch the game, it contains:

Code: Select all

@echo off
EmpyrionLauncher -startDedi
echo.
echo Dedicated server was started as background process
echo Enable Telnet (default port 30004) via dedicated.yaml and connect to it locally
echo for configuration of the server (type 'help' for console commands)
pause
In the panel, we used

Code: Select all

EmpyrionLauncher -startDedi
to start the server in the same fashion the BAT file did.

Please let me know if you need any additional information.

Thank you for your help!

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Fri Nov 11, 2016 1:15 pm

Use task manager to find the command line for the background process (it doesn't show by default you'll need to enable that column). Then try using that info with the executable shown in task manager.
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Re: Empyrion Dedicated Server

Post by aptec » Sat Nov 12, 2016 7:37 am

I tried your suggestion and launched EmpyrionPlayfieldServer.exe however this causes the game to load with a full interface (when I launch the file outside of the panel) and when I launch it with the panel the app will launch however the panel still detects the game isn't running.

Additionally, if we run that file directly the server performance drops significantly as its trying to render graphics as well.

Is there a way I can tell the panel to launch one executable but monitor for another?

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Sat Nov 12, 2016 10:55 am

Ok, I'll further investigate this.
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Sat Nov 12, 2016 1:03 pm

Ok, got it working.

Launching the empyriondedicated server automatically launches the empyrionplayfieldserver as well. When empyriondedicated is stopped, the playfieldserver exits by itself.

My settings:

Code: Select all

Server root:  e:\servers\empyrion
Executable:  %Root%\EmpyrionDedicated.exe
Command line:  -batchmode -nographics -logFile Logs/0712/Dedicated_%DATE%-%TIME%.log
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Re: Empyrion Dedicated Server

Post by aptec » Sat Nov 12, 2016 1:16 pm

I was able to get it working with your settings.

Thank you very much for your help! I appreciate the excellent support!

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Sat Nov 12, 2016 1:22 pm

No problem, glad it's working!
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Re: Empyrion Dedicated Server

Post by aptec » Sat Nov 12, 2016 8:30 pm

Sorry to bother you, I spoke too soon. Panel does notice server is running, but now server take up 100% of one of the cores and doesn't fully come online.

When started with the panel, the server does not show in the in-game server browser, nor does it accept direct connections via IP.

However, it shows in the in-game server browser and will accept direct connections when using the BAT file.

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Sat Nov 12, 2016 9:35 pm

If windows firewall is enabled you'll need to create a rule. Is there any documentation for the server command line options?
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Re: Empyrion Dedicated Server

Post by aptec » Sun Nov 13, 2016 8:34 am

It shouldn't be a firewall issue, I've already created a rule allowing incoming and outgoing traffic for the game's ports.

To make sure, I created a test instance of EzUGCC on my personal computer to start the server with the same config. When I start the server and try connecting to 127.0.0.1 I still can not connect directly nor does it show in the in-game server browser.

I can directly connect to localhost if I start outside of the panel using the bat file like before - same on both the test instance on my personal PC and on the server.

Also, only when starting the server with the panel, the game-server executable take up 100% of one of the cores on the processor. This occurred on the test instance and on the server -- this does not occur with the BAT file on either machine.

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Sun Nov 13, 2016 11:31 am

I'm unable to reproduce the 100% cpu usage issue on my dev machine and EzUGCC test machine.

Which executable is taking up 100% cpu? The empyriondedicated.exe or empyrionplayfieldserver.exe process?

Does the dedicated process launch the playfieldserver process? Are there any hints the logs (\logs\0712\ folder)?

Check to make sure it's not blocked. viewtopic.php?f=21&t=412
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Re: Empyrion Dedicated Server

Post by aptec » Sun Nov 13, 2016 12:02 pm

I found the issue, it appears when switching to the different executable, it caused the game to reset the server config file to default.

After restoring the config file from backup, the server is now loading the correct save, showing in the in-game browser, and now accepting connections.

Now on to integrating Factorio into the panel :)

aptec
Posts: 9
Joined: Sun Sep 04, 2016 10:20 am

Re: Empyrion Dedicated Server

Post by aptec » Sun Nov 13, 2016 12:04 pm

Forgot to say thanks again for your help!

Masher
Site Admin
Posts: 3492
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Re: Empyrion Dedicated Server

Post by Masher » Sun Nov 13, 2016 12:08 pm

No problem! 8)
Masher
-----------
Please do not PM me unless asked to! We are a small company. If you have an issue or question it would be best to post it in the forums where it can help others in the future.

NEW Join our Discord!

mfernald
Posts: 21
Joined: Sun Apr 28, 2019 11:21 am

Re: Empyrion Dedicated Server

Post by mfernald » Mon Mar 30, 2020 5:36 pm

Hi Masher,

Trying the fix you mentioned here and while it allows the panel to see the exe as running, the game server never starts up unless only using -startDedi in the cmd. This is with the EmpyrionLauncher set as the exe. Any help is appreciated and if the OP has any fix for the latest version of Empyrion.

Post Reply