Common Linux Issues

Post Reply
Masher
Site Admin
Posts: 3417
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

Common Linux Issues

Post by Masher » Sat Dec 05, 2009 12:41 pm

Below is a list of items that Linux users may have while installing the panel.

Mono version
UGCC should work with any version of mono greater than 1.9. Some disto's versions of mono are very old. You can check by running 'mono -V'.

Mono version 4.0 and greater
If your SQLite database check fails on the Check.aspx page, you may need to copy Mono.Data.Sqlite.dll from the WWWPanel or WWWPanel-x64's /bin folder (of the deploy archive) to the bin folder of the web panel's install.

Can't connect to MySQL server, and see "CodePage 1252 not supported" in the logs.
Install the libmono-i18n2.0-cil package

When accessing the panel you get an error message about colorconverter, System.Drawing, not a valid color, or anything color related
Install the libgdiplus mono package

When trying to generate a license request, you get an error message that says unable to obtain hardware id
Make sure ifconfig is installed on the box and that it's in the $PATH or a sym link to ifconfig is in the $PATH (ie. /bin)
ln -s /sbin/ifconfig /bin/ifconfig
Masher
-----------
Please do not PM me unless asked to! We are a small company and if you have an issue or question it would be best to post it in the forums where it can help others in the future.

Need an affordable web control panel? Try UGCC.

Post Reply