How to get TBBS to run under 32 bit windows

A support forum for eSoft's TBBS and related software. An alternative support method while www.tbbs.org is down.
Post Reply
Masher
Site Admin
Posts: 3347
Joined: Thu Apr 20, 2006 2:54 pm
Location: America's Hearland
Contact:

How to get TBBS to run under 32 bit windows

Post by Masher » Sun Apr 14, 2013 12:29 pm

It works for some machines, and for some it simply does not. I believe it's reliant on whatever hardware is on the machine. You can try disabling all but the necessary peripherals in the bios.

Edit %SystemRoot%\System32\Config.nt, below is what worked for me. You'll probably need to tweak the B value (keep reading to see how to test, but start with 1000).

Code: Select all

dos=high, umb
device=%SystemRoot%\system32\himem.sys
files=76
EMM = A=255 B=1400 RAM
I made no changes to %SystemRoot%\System32\Autoexec.nt, but it does exist and is loaded when a command prompt is started, just as config.nt is.

Browse to %SystemRoot% in windows explorer, find _default. This contains the default settings for the command shell. Right click and choose properties. Go to the memory tab and set the below settings, then click ok.

Code: Select all

Total Conventional memory:  Auto
Initial environment:  Auto
Protected is checked
EMS Memory:  16384
XMS:  16384
Uses HMA is checked
DPMI:  Auto
Now open a command prompt, type "mem". If you get no output, increase your EMM = B=1000 setting by 100 until the output of mem shows EMS memory in the output list. Now try to start TBBS; with any hope/luck it'll start.

Note on 64 windows operating systems: Microsoft dropped NTVDM support on 64 bit Operating Systems. It's simply not able to run 16 bit applications.
Masher
-----------
Please do not PM me unless asked to! We are a small company and if you have an issue or question it would be best to post it in the forums where it can help others in the future.

Need an affordable web control panel? Try UGCC.

Post Reply